you need to get the latest flash player plugin!!